Okay
  Public Ticket #3555736
The Sliders & other parts are not performing well
Closed

Comments

  • Mohamed started the conversation

    Dear Support Team,

    I am writing to express my disappointment with the performance and functionality of the Layer Sliders plugin I recently purchased. While the plugin offers a variety of templates and customization options, I have encountered several issues that significantly impact its usability.

    Here are some specific problems I have observed:

    • Poor performance: Sliders are slow to load and experience lag during transitions.
    • Missing animations: Certain animations
    • Inaccurate animation timing: The timing of certain animations is noticeably off

    I have attempted to troubleshoot these issues, However, the problems persist.

    I have attached My URL,You can also visit my website at [https://ecommarketings.com/] to see the sliders in action.


  • Mohamed replied

    Dear [Support Team],

    I'm writing to follow up on my previous email, regarding the performance and functionality issues I've been experiencing with the Layer Sliders plugin.

    I haven't heard back from you yet, and I'm hoping you can provide an update on your investigation into these problems. As mentioned in my previous email.

    These issues are significantly impacting the user experience on my website at [ https://ecommarketings.com/ ] and I'm anxious to find a solution as soon as possible.

    Thank you for your time and attention to this matter. I look forward to your prompt response.

    Attached files:  Plugin Invoice.pdf

  •  112
    George replied

    Hello Mohamed,

    I've checked you website. The loading time changes randomly between ultra fast and ultra slow. I realized, that there are several issues on your site where the loading time takes more time. These issues are related to LiteSpeed Cache's "Lazy Load Images" and "Load JS Delayed" features. These features should be disabled, since it can break the proper working of several plugins, like LayerSlider, for example.

    Attached files:  Screenshot 2024-01-08 at 13.30.01.png

    Best Regards,
    George | Kreatura Dev Team

  • Mohamed replied

    Dear George,

    Thank you for investigating the loading time issues on my website that has caused after your plugin installations

    However, I'm ready to give you an accsess to my dashbord to disable the "Lazy Load Images" and "Load JS Delayed" features in LiteSpeed Cache as you suggested. 

    But I'm sure that you will encountering same significant problems with the Layer Sliders plugin

    That's because i have checkedit in completely different website & still not performing as intended.

    Here's a summary of the issues that persist:

    * Layer Sliders:
    * Animations are still missing or not functioning correctly.
    * Timing of animations remains inaccurate.
    ** Website Sections:
    * Inserted sections not working as intended
    ** Pop-ups:
    * Any inserted pop-up not working as intended .

    I understand that LiteSpeed Cache settings may have contributed to some of the problems, but I believe there are additional issues affecting your plugin's functionality.

  •   Mohamed replied privately
  •  112
    George replied

    Hello Mohamed,

    Thank you for the login credentials.
    As I can see, now the loading time is very fast.
    I've found the following issue: several layers are not visible. The reason of this, that your theme applies z-index: 1; to almost every elements. All layers should have z-index: 3; at least, otherwise they will be not visible in certain cases. I've included some custom style rules in LayerSlider CSS Editor which fixed this issue. I cannot see any issues with the animations.

    Best Regards,
    George | Kreatura Dev Team

  • Mohamed replied

    Thanks George for your support.

    Now its much more better than before, But actually we still facing a bit of errors that are still appearing on both desktop & Mobile views:

    * There're a lot of black lines appearing on the sliders itself "As attached" * The Layer slider is affecting the scroll down on mobile view, Scrolling down not working at all. "Please Check the homepage on your mobile phone" * Also need to reduce the higt of layer slider a bit, in order to fix the roll bar at the start screen "As attached".


    Please, I hope these same errors will not repeating in next inserted sliders section's.

    Best Regards, Mohamed Hamad

    Attached files:  Showing in Mobile & Desktop (2).jpg
      Showing in Mobile & Desktop (1).jpg
      Showing in Mobile & Desktop (3).jpg
      Showing in Mobile & Desktop (5).jpg

  •  112
    George replied

    Hello Mohamed,

    Unfortunately, these issues (especially the unwanted black lines) comes from your theme, as you can see on the attached screenshot. Your theme applies a before / after element to EVERY elements with .line class names which are inside a .dark container. Since the slider is in a .dark container element and the slider is using .char, .word and .line elements for the text transition, these style rules are applied to them which causes these kind of graphic issues.

    Best Regards,
    George | Kreatura Dev Team

  • Mohamed replied

    Dear Gerorge

    As for these black lines, Please tell me how to solve the issue, 

    Or try to creat the correct container with the correct options, **With considering the other two points what i have also listed**, I think you didn't check them.

    Then i can copy you correct container & repeat it inside the concerned area's.

    ****************************************** Here are that two points ******************************************

    * The Layer slider affects the scroll down on mobile view, Scrolling down does not work at all. "Check the homepage on your mobile phone"
    * Also need to reduce the height of layer slider a bit, in order to fix the roll bar at the start screen

     

    Best Regards, 

    Mohamed Hamad


    Attached files:  Showing Only in Mobile.jpg
      To reduce the height & to fix similar bar.png

  • Mohamed replied

    Please need your advice to fix these errors accordingly, before you get the weekend off

    Dear Gerorge

    As for these black lines, Please tell me how to solve the issue, 

    Or try to creat the correct container with the correct options, **With considering the other two points what i have also listed**, I think you didn't check them.

    Then i can copy you correct container & repeat it inside the concerned area's.

    ****************************************** Here are that two points ******************************************

    * The Layer slider affects the scroll down on mobile view, Scrolling down does not work at all. "Check the homepage on your mobile phone" * Also need to reduce the height of layer slider a bit, in order to fix the roll bar at the start screen

     

    Best Regards, 

    Mohamed Hamad


    Attached files:  Showing Only in Mobile_687.jpg
      To reduce the height & to fix similar bar_165.png

  • Mohamed replied

    Good Morning George,

    Kind Reminder..

  •  112
    George replied

    Hello Mohamed,

    Unfortunately, I don't know, what should I recommend. Every issues you have are caused by your theme or the not proper settings in your site builder. For example: scrolling is not working on mobile. Yes, because on mobile, the parent container DIV of the slider gets a position: sticky; style property. This is not related to LayerSlider, but you've put LayerSlider into that container which is not moving by user scroll. So I really don't know how can you "fix" that, because I don't know the theme you are using.

    Attached files:  Screenshot 2024-01-11 at 18.32.27.png

    Best Regards,
    George | Kreatura Dev Team

  • Mohamed replied

    Hi George

    The theme what im using is 

    https://axtra.wealcoder.com/

    I geuss now its clear for you to trying to fix it 

  • Mohamed replied

    And what about the 

    * Black lines, Also didnot solved

    * To reduce the height & to fix similar bar



    Attached files:  Showing Only in Mobile_687.jpg
      To reduce the height & to fix similar bar_165.png

  • Mohamed replied

    And please please dont stay other 24 hours to answer me with no soultions.

    Is there is any thing more i can support you, While i gived you full access to try to solve the issues what cused after your plugin (Layer Slider) 

  •  112
    George replied

    I've already answered your question about the black lines. It is caused by the aggressive custom style rules of your theme.

    I'm sorry, but you are wrong: these issues are not related to LayerSlider. These issues caused by your theme but - and this is the problem -  these are affecting the proper working of LayerSlider.

    We cannot take any responsibility for a 3rd party theme/plugin. Our primary concern has always been compatibility, but there is nothing we can do if your theme uses a kind of CSS or JS code that destroys the proper functioning of our plugin.

    "To reduce the height & to fix similar bar"

    I recommend you to simpy place your layers to a little higher, so,  in this way they won't go under the bar.

    Best Regards,
    George | Kreatura Dev Team