Okay
  Public Ticket #3517007
PHP warning errors
Closed

Comments

  • Amanda started the conversation

    Im having this issue on php 7.4

    Warning: Use of undefined constant true  - assumed 'true ' (this will throw an Error in a future version of PHP) in ...../public_html/wp-content/plugins/LayerSlider/layerslider.php on line 47

     and on php 8.2 wich is the default of my hosting the site completely crashes


    this error has been going on forever since LS version 7.8  beleive.

    Ive hiden debug messages on php 7.4 however id like to use php 8.2 at my server as 7.4 will soon stop being supported by my hosting.

  •  70
    John replied

    Hi Amanda,

    Thank you for getting in touch with us. My name is John, and I'm happy to assist you today. I appreciate your patience while we've been working toward your ticket.

    LayerSlider is compatible with both PHP 7.4 and 8.2, and you shouldn't see this error message. I've just tried to reproduce this issue on our test servers without success. I also tried to find earlier reports about it, but yours appears to be the first. 

    The error message itself makes little sense and might suggest a modified file. Can you please tell me what version of LayerSlider you are using and whether it was downloaded from us or from another source?

    Best Regards,
    John | Kreatura Dev Team

  • Amanda replied

    I have found the solution.

    Since Version 7.8 The plugin was failing to recognize the license, even though i had automatic updates available and premium functions enabled.
    had to reinstall the plugin and then re validate the license.

  •  70
    John replied

    Thank you for the feedback, Amanda. I'm glad you could solve the problem.

    Best Regards,
    John | Kreatura Dev Team