Okay
  Public Ticket #2562680
I can't set it to open only once for every new visitor
Closed

Comments

  • Claudiu started the conversation

    Hi, im trying to configure the pop-up to open only once for every unique vistor but didn't had any luck with this. I've tried playing with the settings, but the pop-up still opens every time i visit the homepage. Can you help me with this please? What should i check/do to fix this issue?

  •  116
    Kristof replied

    Hello Claudiu,

    Thank you for getting in touch with us!

    You should set enable the repeat popup and set it to 365 days for example, or 0 for open it in every new browser session.

    If you don't succeed with it, then please send me a wordpress admin temporary to your site.


    Best Regards,
    Kristof Molnar | Kreatura Support Team

  • Claudiu replied

    Hello, I've tried with both 0 and 365 for the repeat field but it still opens every time i visit the home page. I've tried to remove the open automaticaly after 0 seconds but like that it doesn't open at all. I need to request permission for giving you the admin credentials, most probably i will be able to do that tomorrow as for now my work hours are almost finished. Thanks.

  •   Claudiu replied privately
  •  116
    Kristof replied

    Hello Claudiu,

    Thank you for the access.
    Which publishing method do you use for show the popup in your homepage?
    As I see if I disable the slider settings / popup / target pages then the popup is still visible.

    Best Regards,
    Kristof Molnar | Kreatura Support Team

  • Claudiu replied

    I'm using the RT-THEME 18, if you go to RT-THEME 18 from the admin panel then Template Builder and try to edit Default Home Template you will see a block called Layer Slider, there you can choose what slider to play.

  • Claudiu replied

    Also, if you unpublish the slider using LayerSliderWP, it works, the slider won't play anymore, just tested that now.

  •  116
    Kristof replied

    Hello Claudiu,

    Thank you for the answer!

    The issue caused by that you embed LayerSlider to your page with the template builder as a default slider.
    In that case the init code will always run so that's why the repeat options not working.
    If you would like to use popups, then you should use the Target pages / Target audience tabs for show the slider on specific pages. I set it and now the slider visible only once. You should check it in incognito mode for testing.

    Best Regards,
    Kristof Molnar | Kreatura Support Team

  • Claudiu replied

    Thank  you, i'll remove LayerSlider from the theme builder then and i'll try to publish it using the layerslider tag.

  •  116
    Kristof replied

    Hello Claudiu,

    Thank you for the answer!
    You don't need to publish your popup with the default LayerSlider publishing method.
    You should use only the Target pages setting, as I set it in your popup.

    Best Regards,
    Kristof Molnar | Kreatura Support Team

  • Claudiu replied

    I left only Homepage in Target pages but the slider doesn't start. If i try to use the tag it works as before, the slider starts every time i visit the homepage even though it's configured to show only for the first time visitors.

  •  116
    Kristof replied

    Hello Claudiu,

    Thank you for your answer!
    Please revert it back, remove it from your homepage and use the target pages / home, enable the target audience / visitors and set the repeat popup to 0/1 days for example. After that you should check it in incognito browser.

    Best Regards,
    Kristof Molnar | Kreatura Support Team

  • Claudiu replied

    Hello,

    I've removed the layerslider tag from the homepage and enabled target audience, set the repeat to 0 but the popup doesn't start. With the tag on the homepage the popup starts every time, ignoring the target audience setting. The only setting that works is open automatically after 0 seconds, if i remove that it doesn't start even if the tag is set on the homepage.

  • Claudiu replied

    I've noticed that it works now.

  •  116
    Kristof replied

    Hello Claudiu,

    Thank you for the answer!
    I removed the tag from your page and set the popup settings correctly.
    Now it will appear only once for the user in a browser session. It will not visible in your browser, because it stores the cookie of the popup, but you can test it in incognito mode or other browser.
    Please check it.

    Attached files:  popup_settings.PNG

    Best Regards,
    Kristof Molnar | Kreatura Support Team

  • Claudiu replied

    I've tested and everything seems fine now. Thank you!

  •  116
    Kristof replied

    You are welcome!

    Best Regards,
    Kristof Molnar | Kreatura Support Team