Okay
  Public Ticket #2415585
Layer Slider Mobile tablet
Closed

Comments

  • Kris Nelson started the conversation

    Hi,


    Added a Slider - exactly, exactly what I wanted.  Am new to layer slider even though I have owned it for a bunch of years....   No matter what I do, I cannot get this module to display correctly in mobile or tablet view.

    I disabled it using the visibility in Beaver Builder for now so that it can at least be on the desktop version.  

    I would be so very grateful if you would tell me what/where I went wrong and how to correct.  I have tried to research this but am not finding a solution

    https://vikingalternative.com, User Support, PW Kris2066

    Attached files:  Screen Shot 2020-05-25 at 12.15.54 AM.png

  •  93
    Kristof replied

    Hello Kris,

    Thank you for getting in touch with us!

    I tried to login to your admin but I got this error:
    ERROR: Either your Username or Password is Incorrect
    2 attempt(s) left

    Could you please check it and send me a link where I can test you slider or export it and send it to me? (In this case please rename it without whitespace and '-' characters) Thank you, in advance.

    Best Regards,
    Kristof Molnar | Kreatura Support Team

  • Kris Nelson replied

    So sorry - user name Support, password !!Kris2066!!

    I have been working on this problem- have studied and decided to use two plugins this week - the Layer Slider plugin and revolution Slider.  

    I made a slider using layer slider - and this is where my problem appears to be.  I have added just the sliders to https://vikingalternative.com/test-slider to try and isolate the issue.  I love, love your program, but I cannot figure out how to get the slide that I made to be responsive.

    I am in a bit of a mess with this.  The man I made this site for now wants a "fancy" type site with the features and the graphics that you program/plugin allows me to do.  He thinks that this type of site is beyond what I can accomplish as I have not ventured into these types of graphics, spending my learning time on code and other things.  Without asking me, he went and hired a man that he thinks is great - one that uses the Gem theme and a lot of plugins to accomplish everthing - he doesn't seen to know much but can manipulate the plugins to come up with an interesting site.  So that is why it is so important.  I really need to rescue both the site and my reputation and I am STUCK!!!

    I have now broken my home page in mobile - cannot figure out what the problem is or how to fix it, but I think that it is the Layer Slider slide not behaving responsibly that is causing the issue.

    Anything you can do to assist would be greatly - GREATLY - appreciated.  I think I am missing something minor, but I do not know.  

    I am really not stupid - just cannot seem to understand where this problem is.

    Thanks, in advance.

    Kris

    Attached files:  LayerSlider from Viking Alternative site.zip

  • Kris Nelson replied

    I just read an article that said to try duplicating the slide and using the duplicate instead - that Layer Slider IS responsive and there might be something wrong with the original slide.

    Will try that and inster on a new page.

    Kris

  • Kris Nelson replied

    Well....that didn't work either.  I tried putting the slide in a widget instead of an html block - no luck.

    Will wait to hear from you.


    Kris

  • Kris Nelson replied

    Kristof,


    I have no idea what was wrong, but I managed to get it to work.  It would be super helpful to know how to make a  stubborn layer slider be responsive for any future problems if you could explain - that would be fantastic  I cannot find an explanation of how to achieve it.


    Kris

  • Kris Nelson replied

    Well - I have worked all day on this ------ thought it was fixed.  It worked just fine for about an hour and is now broken again.  The main page of my site is a mess - the slide wants to be way, way over to the left hand side, outside the mobile screen.


    Please help.

    Kris

  • Kris Nelson replied

    I have attached an image of what it looks like in edit mode.

    Attached files:  Screen Shot 2020-05-25 at 4.57.49 PM.png

  •  93
    Kristof replied

    Hello Kris,

    Thank you for your feedback!
    As I see there is an overflow issue on your site. If I remove the slider from your homepage, the layout is not good either.

    I set the slider settings / layout / clip slide transition to hide on both axis and disable the prevent slider clipping feature.(You can see them if you enabled the advanced settigns)
    In the test-slider page the layout is correct. There is a scroll in your site because the body is scrollable, you should try this custom css code:
    body { overflow-x: hidden; }

    I tried to add it to the LayerSlider -> Options -> CSS Editor but I couldn't check this tab with this user.

    Best Regards,
    Kristof Molnar | Kreatura Support Team

  • Kris Nelson replied

    Hi,

    I added the code - no luck

    Use the username Kris pw !!Kris2066!!


    I had to go through and modify all pargins and padding on the homepage to make it work correcctly - changed the global margin and padding settings on Beaver Builder to zero which I find is a pain, but have not changed it back.

    In order to get the homepage to display correctly on Mobil after removal of Layer slider, it required going through each module.  

    I will rebuild the homepage on the test slider page and check after the addition of each module to see if we can identify where the problem is - the homepage displays properly until Layer Slider is added.  I am thinking that the code in Layer Slider is causing a conflict with something.

    Any ideas?


    Kris

  •  93
    Kristof replied

    Hello Kris,

    Thank you for your feedback!
    I checked your site on mobile and as I see you solve the issue on the homepage. What was the problem?

    Best Regards,
    Kristof Molnar | Kreatura Support Team