Okay
  Public Ticket #2176708
Pages with slider short code do not render
Closed

Comments

  • chrisleeis started the conversation

    Any page with LayerSlider short code does not render beyond the header (please see related URL).

    From the source code, it looks like the div containing the slider is opened, then something goes wrong and all subsequent code (including closing tags for div, body, html) are blocked.

    No new plugins have been installed since LayerSlider worked.

    I did reconfigure PHP on my server. The server settings section of the LayerSlider system tab shows that ziparchive, DOMdocument, Multibyte String and Multibyte Regex functions are all disabled; however these are all present when I enter the php -m command.

    Can you advise on how to restore functionality to LayerSlider?

  • chrisleeis replied

    ... I fixed it!

    So my server runs php7.3, and all the required mods are enabled in that.

    However, LayerSlider detects (and seemingly uses) php7.2 which is still on the server...

    So I enabled the required mods in 7.2, restarted php, and now the sliders work.

    Can you advise on why LayerSlider is not detecting 7.3?

  •  453
    Attila replied

    Hello Chrisleeis,

    Thank you for getting in touch with us. My name is Attila and I'm happy to assist you today.

    I would like to confirm that we have received your message. Due to the nature of the issue you are experiencing, I will have to contact and consult with the development team first. I will get back to you as soon as I can.

    We appreciate your patience while we're working towards your ticket.

    Best Regards,
    Attila | Kreatura Support Team

  •  453
    Attila replied

    Thank you for your patience. I've contacted with the dev team, and they confirmed that LayerSlider cannot use a different PHP version than the one you are actively using on your whole site, which is set in the virtualhost (or in other configurations). Your server can have multiple PHP versions at the same time, but not all pages will automatically follow up on the newest one you installed, if they are not properly configured.

    Best Regards,
    Attila | Kreatura Support Team

  • Charles-Ed replied

    My issue is this: when I am logged in as Admin-the errors show.

    However, when I am not logged in as admin, the website renders ok. I have attached screenshots.

    Attached files:  Screenshot 31.png
      Screenshot 32.png

  •  453
    Attila replied

    Dear Charles-Ed,

    Please open a new ticket for your case. Thank you.

    Best Regards,
    Attila | Kreatura Support Team