Okay
  Public Ticket #2174343
Anchor links (IDs) set in Layerslider don't work in WPML translation
Closed

Comments

  • e-commerce_schmalz started the conversation

    I created a bilingual website with wordpress using the plugin WPML. On several pages I use different Sliders for the different languages (a German slider for the German page and an English one for the English page). 

    In order to jump to specific section of the page, I added ID tags (such as "#toggle-1" or "#next-section") in the "link and attributes" section. In the German version, everything works perfectly fine. But in the English version, a parameter ("?lang=en") is added twice. Thus, by only adding "#next-section", for instance, I receive a URL like "domain.tld/?lang=en#next-section?lang=en" and, therefore, it doesn't work. 

    I just want to have the full control of the links. How can I achieve that? 

    Thanks in advance!

  •  490
    Attila replied

    Hello Schmalz,

    Thank you for getting in touch with us. My name is Attila and I'm happy to assist you today. I appreciate your patience while we've been working towards your ticket.

    Could you please show us your site or a test page with the slider where we can check on this ?

    Best Regards,
    Attila | Kreatura Support Team

  •   e-commerce_schmalz replied privately
  •  490
    Attila replied

    Thank you. My colleagues and I will look into this to see what we can find, and get back to you shortly.

    Best Regards,
    Attila | Kreatura Support Team

  • e-commerce_schmalz replied

    Thanks a lot!

  •   Attila replied privately
  • e-commerce_schmalz replied

    Hi Attila,

    thanks for your efforts. Do you already know when we can approximately expect the next release?

    Regards

  •  490
    Attila replied

    There is no release date for it, but you can use the version I attached to the previous reply. It already contains this change.

    Best Regards,
    Attila | Kreatura Support Team