Okay
  Public Ticket #2009696
Missing Plugin
Open

Comments

  • YourArtDirector started the conversation

    I have two licenses of LayerSlider, one for met site, one for my development site. I recently when to the development site and noticed that Layerslider was not installed. I went to install it and it failed because it says the folder already exists.

    I have a couple Questions: 
    1. How do I get back on my development site?
    2. I assume the sliders I made will be ion the development site if I get the plugin installed, if not how do I copy them from the live site to the development site?
    3. Why did the plugins disappear, I assume it has to do with copying the site from the Development site to the live site, how do prevent this from happening again?

  •  400
    Attila replied

    Hello YourArtDirector,

    Thank you for getting in touch with us. My name is Attila and I'm happy to assist you today. I appreciate your patience while we've been working towards your ticket.

    The plugin was most likely deactivated in the WP Plugins menu. Or your theme might also load a bundled version, overwriting the original one, and in that case it needs to be disabled. But the first case is more likely.

    The sliders are stored in the database, so they should be there after the reinstall. But LayerSlider also provides an import/export feature that you can use for this purpose.

    LayerSlider cannot deactivate/delete itself, but WordPress might disable plugins automatically in rare cases, for example when it couldn't update them properly, or when the plugin's location/path has changed.

    Best Regards,
    Attila | Kreatura Support Team

  • YourArtDirector replied

    Let me try and make this really clear.

    I went to my staging site a couple days ago and the layer sliders were not working. I went to the plugins folder and there was no layer slider installed, I searched by looking, and by typing keywords, it was not there. Also the folder, in the left nav of WordPress, that had the layer slider files was gone. I had just received a notice I need to extend my license so I could get support for this slider so I went and did that and downloaded the slider. I went to install it and it says it could not install because the folder already exists. At this point I emailed you.

    Last night I did a push from my development site to my live site and the layer sliders stopped working. I looked in the plug ins folder and did see a deactivated layer slider. I went to activate it and immediately got this error on the front and back end. 

    Fatal error: Uncaught Error: Call to undefined method LS_Config::isActivatedSite() in /home/content/a2pewpnaspod05_data06/69/41670369/html/wp-content/plugins/LayerSlider/wp/notices.php:12 Stack trace: #0 /home/content/a2pewpnaspod05_data06/69/41670369/html/wp-includes/class-wp-hook.php(286): layerslider_check_notices('') #1 /home/content/a2pewpnaspod05_data06/69/41670369/html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /home/content/a2pewpnaspod05_data06/69/41670369/html/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /home/content/a2pewpnaspod05_data06/69/41670369/html/wp-admin/admin.php(169): do_action('admin_init') #4 {main} thrown in /home/content/a2pewpnaspod05_data06/69/41670369/html/wp-content/plugins/LayerSlider/wp/notices.php on line 12

    The site is down, and has been for a couple hours.

    I went back to the development site and searched again for Layerslider, layer slider, layer, slider, and Kreatura. It is not in the plugins folder. I tried one more time to install is and got this message, 

    Installing Plugin from uploaded file: layersliderwp-6.8.4.installable.zip
    Note: This is a staging site.
    Unpacking the package…
    Installing the plugin…
    Destination folder already exists. /home/content/a2pewpnaspod04_data02/44/41671544/html/wp-content/plugins/LayerSlider/
    Plugin installation failed.
    Return to Plugin Installer

    I am now going to push the development site in hopes of getting the site back up.

    Thank you, I would appreciate any help you can offer.

    Kenton

  • YourArtDirector replied

    Update: The site came back up after pushing the development site to the live site again.

    As you can see from the three screen shots, I have Layer Slider 6.8.3 installed, I did not activate it again since it took the site down last time. I tried to upgrade it to 6.8.4, you can see from the second screen capture. Then it failed, just like on the development site, that doesn't have a layer slider in the plugins folder. 

    Also 6.8.3 is not saying there is an update.

    Attached files:  Screen Shot 2019-05-14 at 6.43.27 PM.png
      Screen Shot 2019-05-14 at 6.44.02 PM.png
      Screen Shot 2019-05-14 at 6.44.36 PM.png

  •  400
    Attila replied

    Thank you for the feedback. 

    The problem is that you cannot update the plugin by uploading it again when it's already installed. There cannot be two instances of the plugin present on your installation at the same time. That is why the 'destination folder already exists' error message appears, and after the error, the existing location of the plugin is listed. If you would like to update it this way, you will first have to remove it (WP->Plugins->LayerSlider->Delete) and then install it again: https://layerslider.kreaturamedia.com/documentation/#installation

    Another way to update the plugin, is to use your license to activate it and then utilizing the auto-update feature: https://layerslider.kreaturamedia.com/documentation/#updating-auto

    You can find step-by-step instructions on how to install and update the plugin in the documentation, linked above.

    Best Regards,
    Attila | Kreatura Support Team

  • YourArtDirector replied

    How do you uninstall it if you can't see it in the plugins folder? Will this also delete all the layer sliders I have made?

  •  400
    Attila replied

    You do not have to look for its folder. Just delete it in the mentioned way from WordPress dashboard: WP->Plugins->LayerSlider->Delete. It is showing on your screenshot.

    As also mentioned earlier: The sliders are stored in the database, so they should be there after the reinstall. But you can always export them first, just to be extra safe.

    Best Regards,
    Attila | Kreatura Support Team

  • YourArtDirector replied

    I managed to fix it. Since I could see the plugin on the live site I deleted it and reinstalled the new version. That fixed the issues on the live site. Then pushed the live site to the development site and installed the new version. Both sites seem to working and my files here not lost.

    Question: Right now it seems to be working with one license for both site because the license info copies from one site to the other. Is this okay? I have two licenses, but it changes when I push an update.

  •  400
    Attila replied

    One license can be used for one live site only. Using it on two separate sites simultaneously will likely result in an activation cancel or stuck activation. However you can still use it on dev sites as explained here: https://layerslider.kreaturamedia.com/documentation/#activation-sites

    Best Regards,
    Attila | Kreatura Support Team