Okay
  Public Ticket #1600292
Popup triggered by button only working intermittently and not on iPad
Closed

Comments

  •  2
    Word2Art started the conversation

    Hi there,

    I am having an issue with a Layerslider popup that is triggered by clicking the orange button on the home page above the fold section that says "Get an Audit". If I set the popup repeat frequency to 0, on desktop (I"m logged into admin panel, not sure if that has something to do with it) it pops up all the time. If I delete the repeat frequency and leave it blank, it doesn't pop up at all - on new load,, browser refresh or incognito window.  No matter what I do, it won't pop up on ipad or mobile. 

    I have removed all minification from Cloudways hosting caching plugin  Breeze, and the sliders now seem to be working consistently on ipad, so that is great news! But the audit popup button is not working and I don't think this can be a  minification issue.

    It's the discount popup slider.

    In case it's of assistance, I am including admin panel access.

  •  305
    Attila replied

    Hello Sharon,

    Thank you for getting in touch with us. My name is Attila and I'm happy to assist you today. I appreciate your patience while we've been working towards your ticket.

    The problem is that you have set the popup hidden for admins (Target Audience -> Show popup for users -> Admins OFF). That is why you cannot see it, or anyone who's logged in with the same permissions.

    Best Regards,
    Attila | Kreatura Support Team

  •  2
    Word2Art replied

    Hi Atilla,

    I have been testing incognito. I turned off admins because for some reason the popup was displaying over and over again (which it shouldn't have been doing on the selected repeat setting) and it was driving me crazy!

    There is definitely an issue - it's very temperamental, and is displaying either multiple times or not at all when I test - even on browser reload.

  •  305
    Attila replied

    We've tested it with my colleagues, but we couldn't reproduce this issue on our end. The popup was working as intended in line with the applied settings. The only problem we noticed that it was turned off for admins.

    Regardless, we are going to take another look to see if we can find anything else that might be causing this.

    Best Regards,
    Attila | Kreatura Support Team

  •  305
    Attila replied

    Sorry for the delayed response. We've investigated this thoroughly to locate the origin of this error. But after hours of testing on multiple devices we were still not able to recreate this problem on our end. So it is more than likely a localized issue.

    One more thing you could try is to avoid using the Target Pages method and instead use shortcode to insert the popup. After that only use the click trigger to launch the popup and disable prevent reopening.

    And we'd also recommend to empty cache/cookies/etc on your browser. It's possible that an old version is still being loaded for you.

    Best Regards,
    Attila | Kreatura Support Team