Okay
  Public Ticket #1196176
Layer Slider won't show on most of my browsers
Closed

Comments

  • meldrum78 started the conversation

    Hello,

    I just upgraded to pro version today on my wordpress site using High End theme.  It originally came with Layer Slider but I had deactivated it.  I reactivated and upgraded it today and put together a really nice slider for my home page but it doesn't show anything on Chrome, Edge, and Firefox.  It works on Internet Explorer and on my Android phone.  What's going on?  I'd hate to think I wasted money on this and, even worse, wasted time on this?  What can I do to remedy this problem?

    Thanks,

    Dan

  •  499
    Attila replied

    Hey Dan,

    I do not see any trace of a slider being inserted to the URL you have provided. Did you remove it in the meantime ?

    Also, what method have you used exactly to insert the slider ? Did you use one of the plugin's built-in methods (shortcode,widget,php function) or a page builder ?

    Best Regards,
    Attila | Kreatura Support Team

  • meldrum78 replied

    Hi Attila,

    Yes, I had removed it and replaced it with a different screen as I can't trust it to work.  So what I've just done is created a page here at http://www.danceofthecosmos.com/slider/.  I am using Visual Composer to make this.  Just simply choosing the option to make the Layer Slider as the only function of the page to make it simple.  In Visual Composer, I just choose Layer Slider as the element and this places it inside of a "Row".  It automatically defaults to the slider that I've created called "Home slider".

    Thanks,

    Dan

  •  499
    Attila replied

    There was a similar issue to what you're experiencing in the older versions of Visual Composer, we have reported this issue to the authors and it should be fixed in the latest release.
    The problem is related to the VC's dedicated LayerSlider module. In case you are still epxeriencing this issue with the latest version of VC as well, you will need to use a different module, for example text module and insert the slider with its shortode to bypass this error. You can still use VC, just not the LayerSlider module, as it seems to be still broken.

    As an alternate solution you could also try to disable the "Include scripts in footer" and "Conditional script loading" advanced settings in LayerSlider. This also seems to help, but if you need these options it's recommended to go with the previous method.

    Best Regards,
    Attila | Kreatura Support Team

  • meldrum78 replied

    Hi Attila,

    I tried what you recommended.  I used the code [layerslider id="1"] which is not using VC and just in the normal text box.  Still nothing.  It's currently set up this way on this link here.  In advanced settings of Layer Slider, those two options were currently switched off.  I tried turning both of them on and off and still it doesn't work.  Very disappointing.

    Thanks,

    Dan

  •  499
    Attila replied

    There seems to be another issue on your site. There are jQuery errors (jQuery is not defined) in the console. This usually means that your jQuery is not loaded or not in the right way. LayerSlider needs it be loaded in the header to be able to display the slider properly.

    If you're not familiar with jQuery you can try to use the Put JS includes to body advanced setting to see if that helps.

    Please also check if you're using the Rocketscript feature of Cloudflare, as it interferes with jQuery therefore our plugin.

    Best Regards,
    Attila | Kreatura Support Team